T-Mobile and AT&T will require VoLTE for calls after shutting down 3G

0
5

The constant evolution of network technology is exciting to follow but only if you have the means to stay up-to-date with new advancements. In our industry, that means buying new smartphones, routers, and plans from carriers. Furthermore, you have to make sure that whatever you purchase is actually compatible with the network you’re paying for. This week has reminded us once again of the importance of network compatibility, as we’re reminded that both AT&T and T-Mobile will eventually shut down their 3G networks. This shouldn’t come as a surprise since both carriers are in the process of rolling out their 5G networks, but it’s important to note because of the complicated nature of VoLTE on Android.

If you’re unfamiliar with VoLTE, it stands for “Voice over LTE” and it’s exactly what it sounds like. Phone calls are routed over a 4G LTE connection instead of 2G or 3G. A few years ago, this was seen as a big deal as the higher bandwidth of 4G LTE means that more data can be transmitted, resulting in reduced compression of voice data and thus better call quality for both parties. VoLTE is pretty standard nowadays, with pretty much all of the major carriers having implemented it and all devices with cellular modems supporting the technology. In fact, T-Mobile’s Q1 2020 earnings report states that “VoLTE comprised 91% of total voice calls” on the network. Many carriers have already shut down their legacy 2G networks because the vast majority of customers have upgraded to devices compatible with newer network technologies, and the carriers are gearing up to shut down their 3G networks, too.

Earlier today, AndroidPolice published a screenshot of an internal T-Mobile notice that reveals that the carrier will require VoLTE for all devices connecting to its 4G LTE and 5G networks. The publication also reported on emails that were sent to customers of AT&T informing them that their phones will eventually become incompatible with the carrier’s network. Here’s what you need to know about the upcoming shutdown of T-Mobile and AT&T’s 3G voice networks.

T-Mobile’s VoLTE Requirement – Coming Soon

T-Mobile’s VoLTE Device Compatibility Requirements. Source: T-Mobile. Via: AndroidPolice.

Starting August 4th, 2020, T-Mobile will stop activating new devices that do not support VoLTE on its network. T-Mobile says that all devices in its current lineup (meaning, devices sold through them) support VoLTE.

Starting January 2021, any device that does not support VoLTE on T-Mobile will no longer be able to connect to the carrier’s 4G LTE or 5G network. Existing T-Mobile and Metro by T-Mobile (formerly known as MetroPCS) customers who activate a non-VoLTE-compatible device before August 4th will be informed via a text message that their device will become incompatible with the network starting January 2021.

Although it hasn’t been confirmed yet, it’s possible that some devices purchased via Sprint will be affected by this change. Sprint has always required certification for devices to connect to its network, and that certification has included VoLTE compatibility. However, T-Mobile is in the process of refarming Sprint’s network to expand its own 5G network, so it’s possible that some Sprint devices won’t be VoLTE compatible with the new T-Mobile network.  We also don’t know how this change will affect devices from the myriad of other MVNOs that use T-Mobile’s network, including Ting, Consumer Cellular, and Mint Mobile.

T-Mobile issued the following statement to AndroidPolice in regards to this notice:

We’re making great progress building a truly transformative nationwide 5G network. As part of that, we will be phasing out some older technologies over time to free up even more capacity for LTE and 5G. In preparation for that and to give customers the best experience, those activating new lines at T-Mobile will need a VoLTE capable device, which is all we’ve offered for years now and represents the overwhelming majority of devices on the network.

The carrier, however, declined to explicitly confirm the timeline of its 2G and 3G voice network shutdown.

AT&T’s 3G Shutdown – Coming February 2022

Earlier this week, AT&T (poorly) warned many customers that they should upgrade their smartphones soon as their devices will soon become incompatible with the carrier’s network. AT&T sent out emails to customers telling them their device “is not compatible with the new network and [they] need to replace it to continue receiving service.” The part that AT&T failed to explicitly mention to customers is that they won’t be affected by this change until February 2022. The email, as it was worded, clearly suggested that customers take urgent action to upgrade their device, even going as far as outlining steps to “easily” get a new device.

To its credit, AT&T is at least informing customers of its impending 3G network shutdown well ahead of T-Mobile, but they did so incredibly poorly. AT&T provided a statement to AndroidPolice to clarify that this email was the first of many it plans to send to customers to keep them informed of the impending shutdown of the carrier’s 3G network. Here’s the statement the carrier sent to the publication:

This email was one of many planned to keep customers informed about the shutdown of our 3G network in early 2022. It should have included the date that certain devices would no longer be supported. We apologize for any confusion this may have caused and will be more clear in future updates.

So AT&T, like T-Mobile, will require all devices connected to its network to support VoLTE. AT&T calls this “HD Voice,” and like T-Mobile, will block voice and data service for phones that don’t support it. AT&T, unlike T-Mobile, whitelists devices for VoLTE/HD Voice. That whitelist, available here, includes the Essential Phone, all Google Pixel phones since the Pixel 2, the LG G7 and V35, 9 Motorola devices, the OnePlus 7 Pro and 7T Pro, and all Samsung Galaxy flagships since the S8.

What this means for BYOD, unlocked devices, and custom ROMs

If you have purchased a recent smartphone directly from AT&T or T-Mobile, then you very likely have nothing to worry about here. However, if you’re using an unlocked device or a device on a custom ROM, then you’ll want to pay attention to what’s coming. Since AT&T whitelists devices for VoLTE compatibility, you won’t be able to BYOD to the carrier starting February 2022 unless the carrier changes its practices or whitelists a lot more devices. There’s no reason they can’t—VoLTE is a standard protocol, after all—but thus far they haven’t. There’s nothing you, the device maker, or a custom ROM developer/modder can do about it.

While T-Mobile, on the other hand, doesn’t use a whitelist for VoLTE compatibility, many unlocked devices just straight up don’t support it regardless. The recently announced ASUS ROG Phone 3 does not currently support VoLTE on the network, for example. It’s not that these phones can’t support VoLTE on T-Mobile, it’s just that the device maker hasn’t done the work to outright support it. Modders on our ROG Phone II forums have figured out the steps needed to enable VoLTE on T-Mobile, proving that a little more work at the factory could enable support.

Theoretically, as long as your Android device has a working IMS (IP Multimedia Subsystem) stack, it should support VoLTE on T-Mobile (but not AT&T because of its whitelist system.) Typical Android devices with Qualcomm modems ship with a privileged application that bridges the radio interface layer (RIL) and the IMS, which developers take bundle in their custom ROMs to enable VoLTE support. LineageOS, for example, requires maintainers to support VoLTE if the stock ROM supports it. If the stock ROM doesn’t support it, then it’s unlikely you’ll be able to use the device on AT&T or T-Mobile once they shut down their 3G networks.

One more thing we need to talk about is support for phones purchased overseas. It’s likely that if your phone has the right hardware (which nearly all do) and the right IMS configuration (a bit iffier) to support VoLTE on T-Mobile and AT&T, then you’ll be able to make VoLTE calls on both networks, provided your carrier back home has a roaming agreement.

How to check if your phone supports VoLTE

There’s a pretty easy way to check if your phone supports VoLTE on your current carrier. Simply install the “Network Mode Universal” app from the Google Play Store, turn on mobile data (and turn off Wi-Fi so you don’t accidentally trigger VoWiFi), and make a phone call to another number. If the “Voice Network Type” line shows “LTE,” then your phone call is being routed over LTE. Congrats, your phone supports VoLTE on your carrier! If you see anything other than LTE, like GSM, WCDMA, UMTS, or just 3G, then your phone does not support VoLTE on the network. In this case, talk to the customer support of your carrier for your next options.

Thanks to AndroidPolice for bringing this app to our attention.

Source link

LEAVE A REPLY

Please enter your comment!
Please enter your name here